AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  Connexion  

Partagez | 
 

 [Résolu]Je n'arrive pas à attacher les roues correctement à la voiture

Aller en bas 
AuteurMessage
Ghatos
Utilisateur moyen
avatar

Messages : 69
Projet Actuel : Un jeu en 2D sur Game maker studio(parce que je ne sais faire que ça hap )

MessageSujet: [Résolu]Je n'arrive pas à attacher les roues correctement à la voiture   Ven 3 Nov 2017 - 20:14

bonjour! colors

je suis actuellement en train de faire un jeu de voiture vu de côté (un peu comme hill climb racing)
j'ai crée un objet voiture qui crée 2 roues lorsqu'il est crée (L_wheel, qui est la roue arrière, et R_wheel qui est la roue avant)
pour les attacher ensemble (les roues à la voiture), j'utilise des "clous":
pour la roue arrière:
Code:
physics_joint_distance_create(SUV, L_wheel, SUV.x - 186, SUV.y + 150, L_wheel.x, L_wheel.y, false)

et pour la roue avant:
Code:
physics_joint_distance_create(R_wheel, SUV, SUV.x + 150, SUV.y + 150, R_wheel.x, R_wheel.y, false)

le problème avec ce type de "clou", c'est que la roue peut bouger du point où il est attaché, aussi bien verticalement qu'horizontalement, donc l'avant de la voiture se met à frotter le sol souvent, tout comme l'arrière :/
il y a pourtant des "clous" fait pour les voitures:
Code:
physics_joint_wheel_create(inst1, inst2, anchor_x, anchor_y, axis_x, axis_y, enableMotor, max_motor_torque, motor_speed, freq_hz, damping_ratio, col)

sauf que je ne sais pas ce que font "axis","freq_hz" et "damping_ratio"  triste2
pareil pour tout les trucs "motor"  Crying or Very sad
et quand j'essaye d'utiliser ce type de "clou", la voiture se téléporte à l'autre bout de la map (en tous cas, c'est l'impression que j'ai)
j'ai essayé de m'aider avec le site de yoyogame, mais je ne comprends presque rien à ce qui est dit Sad
comment je fais pour attacher correctement des roues à la voiture?

EDIT: Aucune réponse en 1 jour?  gha  vous non plus, vous ne savez pas comment faire?
EDIT 2: En fait, j'ai trouvé une vidéo qui expliquait comment faire:

Revenir en haut Aller en bas
 
[Résolu]Je n'arrive pas à attacher les roues correctement à la voiture
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [résolu]Le printemps arrive !!
» meilleurs voeux pour la nouvelle annee qui arrive
» Une carte postale arrive 72ans après.
» [résolu] Impossible de sauvegarder ma généalogie + geneo
» Je n'arrive pas a me connecter

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum Le CBNA :: Développement :: Entraide débutants-
Sauter vers: