AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  Connexion  

Partagez | 
 

 [Résolu] Particule problème

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
FlavoursGames
Très bonne participation


Messages : 111

MessageSujet: [Résolu] Particule problème   Mar 23 Juil 2013 - 17:23

Bonjour a tous !
ma question est toute bête et pourtant je n'arrive pas a trouver de solution.. comment faire pour que ma particule ce mette au dessus de l'objet ?

Voici le code de ma particule (repris du manuel de game maker, je m'entraine lol) :

Code:
 // make the particle system
  ps = part_system_create();
  // the firework particles
  pt1 = part_type_create();
  part_type_shape(pt1,pt_shape_flare);
  part_type_sprite(pt1, sAchievementBouton2, true, true, true)
  part_type_size(pt1,0.1,1,0,0);
  part_type_speed(pt1,1,5,0,0);
  part_type_direction(pt1,0,360,0,0);
  part_type_life(pt1,20,30);
  part_type_gravity(pt1,0.2,270);
  part_particles_create(ps,view_xview+442, view_yview+234, pt1, 20);
Il n'y as pas une function du type : part_particles_below ou autres ??


Dernière édition par FlavoursGames le Mar 12 Nov 2013 - 12:41, édité 3 fois
Revenir en haut Aller en bas
Kabcorp
Utilisateur confirmé: Rang **
avatar

Messages : 315
Localisation : Savoie
Projet Actuel : trop...

MessageSujet: Re: [Résolu] Particule problème   Mar 23 Juil 2013 - 17:53

// make the particle system
ps = part_system_create();
// the firework particles
pt1 = part_type_create();
part_type_shape(pt1,pt_shape_flare);
part_type_sprite(pt1, sAchievementBouton2, true, true, true)
part_system_depth(pt1,DEPTH) <---------------------------------------------------------------
part_type_size(pt1,0.1,1,0,0);
part_type_speed(pt1,1,5,0,0);
part_type_direction(pt1,0,360,0,0);
part_type_life(pt1,20,30);
part_type_gravity(pt1,0.2,270);
part_particles_create(ps,view_xview+442, view_yview+234, pt1, 20);

_________________
Vous voulez un jeu pas comme les autres? Voici DeFRaG :
 
Revenir en haut Aller en bas
http://kabcorp.fr
FlavoursGames
Très bonne participation


Messages : 111

MessageSujet: Re: [Résolu] Particule problème   Mar 23 Juil 2013 - 19:51

A oui j’oublie toujours que sa s’apel depth ! Merci beaucoup Kab ! Smile
Revenir en haut Aller en bas
Kabcorp
Utilisateur confirmé: Rang **
avatar

Messages : 315
Localisation : Savoie
Projet Actuel : trop...

MessageSujet: Re: [Résolu] Particule problème   Mar 23 Juil 2013 - 22:07

clinoeuil 

_________________
Vous voulez un jeu pas comme les autres? Voici DeFRaG :
 
Revenir en haut Aller en bas
http://kabcorp.fr
FlavoursGames
Très bonne participation


Messages : 111

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 20:20

Bonjour a tous !

J'ai un autre petit problème avec mes particles..
Je voudrais qu'ils suivent la view, ou plutot qu'ils s’exécutent a l’écran sans bouger si la view bouge.

Le code de ma particle ce trouve dans un évènement alarme :

Code:
  ps = part_system_create();
  pt1 = part_type_create();
  part_type_shape(pt1,pt_shape_flare);
  part_type_sprite(pt1, sConfetis, true, true, true)
  part_type_size(pt1,0.1,1,0,0);
  part_type_speed(pt1,1,10,0,0);
  part_type_direction(pt1,0,360,0,0);
  part_type_life(pt1,20,50);
  part_type_gravity(pt1,0.2,270);
  part_system_depth(ps,-30)
  part_particles_create(ps,view_xview+652, view_yview+44, pt1, 20);
  part_particles_create(ps,view_xview+852, view_yview+144, pt1, 20);
  part_particles_create(ps,view_xview+452, view_yview+100, pt1, 20);
Voila si quelqu'un a une idée a me proposer mop 

Revenir en haut Aller en bas
onilink_
Modérateur
avatar

Messages : 8904
Localisation : Montpellier
Projet Actuel : Planet Centauri
OniDev

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 20:35

TFM a écrit:
part_system_position(ind,x,y) Sets the position where the particle system is drawn. This is normally not necessary but if you want to have particles at a position relative to a moving object, you can set the position e.g. to that object.

_________________
                 
Revenir en haut Aller en bas
Asu
Utilisateur confirmé: Rang ****
avatar

Messages : 895

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 20:44

onilink_ a écrit:
TFM a écrit:
part_system_position(ind,x,y) Sets the position where the particle system is drawn. This is normally not necessary but if you want to have particles at a position relative to a moving object, you can set the position e.g. to that object.
Version anglophobes :
part_system_position(ind,x,y) Règle la position où le système de particule est dessiné. Ce n'est normallement pas nécessaire mais si vous voulez avoir des particules à une position relative à un objet qui bouge, vous pouvez régler la position par exemple à cet objet.

_________________
‎<‎Cysteine‎>‎ nON mais la touche maj s'active/se désactive toute seule
‎<‎Cysteine‎>‎ et a du mal à réponDRE QUANd j'appuie dessus
‎<‎Cysteine‎>‎ et je l'ai démont2? IL Ny a rien DEDANs
Revenir en haut Aller en bas
FlavoursGames
Très bonne participation


Messages : 111

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 20:53

Je dois mal configurer cette fonction alors, car j’avais déjà essayé, et sa n'avait rien donnée du moin on ne voyait pas la particules a l'écran ou alors sa n'avais aucun effets.
J'avais essayer comme sa " part_system_(ps, view_xview+652, view_yview+44); "
Je vais essayé avec d'autres valeurs, merci (: .
Revenir en haut Aller en bas
onilink_
Modérateur
avatar

Messages : 8904
Localisation : Montpellier
Projet Actuel : Planet Centauri
OniDev

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 20:59

FlavoursGames a écrit:
part_system_(ps, view_xview+652, view_yview+44);
A moins que ton écran soit très large, ça risque effectivement d'être affiché pas mal a droite de ta vue :b
Surtout les particules doivent être crées a une valeur fixe proche de l'origine, et non pas en (view_xview+652, view_yview+44) sinon tu risques de les perdre.

_________________
                 
Revenir en haut Aller en bas
FlavoursGames
Très bonne participation


Messages : 111

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 21:05

Lol oui sa doit être pour sa que je ne les vois pas.
Je crée mes particule a cette valeur la " part_particles_create(ps,view_xview+652, view_yview+44, pt1, 20); "

donc pour qu'il garde la même position je rentre les même valeurs non ?


Dernière édition par FlavoursGames le Lun 11 Nov 2013 - 21:10, édité 2 fois
Revenir en haut Aller en bas
onilink_
Modérateur
avatar

Messages : 8904
Localisation : Montpellier
Projet Actuel : Planet Centauri
OniDev

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 21:08

Bah dans l'idée tu dois créer tes particules en (0, 0), ce sera le part_system qui s'occuperas de tout afficher ou il faut avec part_system_position.

_________________
                 
Revenir en haut Aller en bas
FlavoursGames
Très bonne participation


Messages : 111

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 21:18

j'ai donc essayé sa :

Code:
  part_particles_create(ps, 0, 0, pt1, 20);
  part_system_position(ps,view_xview+652, view_yview+44);
Mais la particule continue de bouger : /
Revenir en haut Aller en bas
onilink_
Modérateur
avatar

Messages : 8904
Localisation : Montpellier
Projet Actuel : Planet Centauri
OniDev

MessageSujet: Re: [Résolu] Particule problème   Lun 11 Nov 2013 - 22:39

Tu updates part_system_position chaque step?
Et quand tu dis la particule, tu parles bien du part_system? (vu que ta particule a une vitesse, logique qu'elle bouge)

_________________
                 
Revenir en haut Aller en bas
FlavoursGames
Très bonne participation


Messages : 111

MessageSujet: Re: [Résolu] Particule problème   Mar 12 Nov 2013 - 9:07

Oui je parle bien du part system Smile. Enfaite c'est bien ce que je pensais que je devais le mettre dans l’évènement "step" c'est sa ? Pour qu'il ce mette a jour automatiquement, le problème c'est que je lançais la particule depuis une alarme. Je vais mis prendre autrement alors Smile.
Revenir en haut Aller en bas
onilink_
Modérateur
avatar

Messages : 8904
Localisation : Montpellier
Projet Actuel : Planet Centauri
OniDev

MessageSujet: Re: [Résolu] Particule problème   Mar 12 Nov 2013 - 10:59

T'as juste besoin de mettre le part_system_position dans un step. Le reste tu peux le laisser dans ton alarm.

_________________
                 
Revenir en haut Aller en bas
FlavoursGames
Très bonne participation


Messages : 111

MessageSujet: Re: [Résolu] Particule problème   Mar 12 Nov 2013 - 12:41

Nikel ! You are the king 0/
Enfaite quand je le mettais dans le step sa marchais pas car j'oubliai de déclarer la particle dans l’évènement create plutôt que l'alarme sweat 

Merci Smile.
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: [Résolu] Particule problème   

Revenir en haut Aller en bas
 
[Résolu] Particule problème
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [résolu] - 1505 problème dictionnaire des noms Heredis 2000
» [résolu] Problème avec fichiers BKH
» [résolu]Problème à l'ouverture d'un fichier H13
» problème pour allez faire " caca "
» Problème application eyeliner !!!!

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum Le CBNA :: Développement :: Entraide débutants-
Sauter vers: